Scheduled Maintenance
Incident Report for Untappd
Resolved
Scheduled maintenance complete
Posted Jun 27, 2023 - 08:31 EDT
Monitoring
Billing and Payments may be impacted during this timeframe.
Posted Jun 27, 2023 - 08:14 EDT
This incident affected: Business (Untappd for Business).