Web pages very slow to load

Incident Report for Untappd

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 11:15 EDT

Monitoring

The slowness seems to have subsided and we are monitoring.
Posted Mar 14, 2025 - 15:51 EDT

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 15:39 EDT
This incident affected: Consumer (Untappd (Web)).