untappd.com Issues

Incident Report for Untappd

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:48 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2025 - 14:51 EDT

Investigating

untappd.com pages are slow to load and various actions are not working as expected. We are currently investigating.
Posted Apr 01, 2025 - 14:36 EDT
This incident affected: Consumer (Untappd (Web)).